CVE-2025-9141 is a high-severity (CVSS 8.8) remote code execution vulnerability in vllm. A fix is available for vllm — see the affected versions and patch details below.
vLLM has remote code execution vulnerability in the tool call parser for Qwen3-Coder
Real-World Exposure
vllmReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
An unsafe deserialization vulnerability allows any authenticated user to execute arbitrary code on the server if they are able to get the model to pass the code as an argument to a tool call.
Details
vLLM's Qwen3 Coder tool parser contains a code execution path that uses Python's eval() function to parse tool call parameters. This occurs during the parameter conversion process when the parser attempts to handle unknown data types.
This code path is reached when:
- Tool calling is enabled (
--enable-auto-tool-choice) - The qwen3_coder parser is specified (
--tool-call-parser qwen3_coder) - The parameter type is not explicitly defined or recognized
Impact
Remote Code Execution via Python's eval() function.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | vllm | ≥ 0.10.0&&< 0.10.1.1 | 0.10.1.1pip install --upgrade 'vllm==0.10.1.1' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vllm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vllm to 0.10.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-9141 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2025-9141 in your dependencies?
Find it across PyPI, including transitive dependencies.