NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2025-9079 — mattermost-server

HIGHFix: mattermost/mattermost@047a2c6

CVE-2025-9079 is a high-severity (CVSS 8) Path Traversal vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Admin RCE via prepackaged plugins by way of misconfigured imports directory

Also known asGHSA-qx3f-6vq3-8j8mGO-2025-3977
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-9079.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.38%0.76%1.14%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to validate import directory path configuration which allows admin users to execute arbitrary code via malicious plugin upload to prepackaged plugins directory

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server≥ 10.8.0&&< 10.8.410.8.4go get github.com/mattermost/mattermost-server@v10.8.4
🐹Gogithub.com/mattermost/mattermost-server≥ 10.5.0&&< 10.5.910.5.9go get github.com/mattermost/mattermost-server@v10.5.9
🐹Gogithub.com/mattermost/mattermost-server≥ 9.11.0&&< 9.11.189.11.18go get github.com/mattermost/mattermost-server@v9.11.18
🐹Gogithub.com/mattermost/mattermost-server≥ 10.10.0&&< 10.10.210.10.2go get github.com/mattermost/mattermost-server@v10.10.2
🐹Gogithub.com/mattermost/mattermost-server≥ 10.9.0&&< 10.9.410.9.4go get github.com/mattermost/mattermost-server@v10.9.4
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20250707221302-a8fa77f107efgo get github.com/mattermost/mattermost/server/v8@v8.0.0-20250707221302-a8fa77f107ef

Affected Products

1 product · 5 configurations
Application
mattermost servermattermost
≥ 10.10.0 && < 10.10.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 10.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-9079 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to validate import directory path configuration which allows admin users to execute arbitrary code via malicious plugin upload to prepackaged plugins directory
O3 Security · Impact-Aware SCA

Is CVE-2025-9079 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-9079: mattermost-server RCE — Fixed in 10.8.4