NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2025-9072 — mattermost-server

HIGHFix: mattermost/mattermost@13cd760

CVE-2025-9072 is a high-severity (CVSS 7.6) Open Redirect vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

One-Click Mattermost Account Takeover via Poisoned RelayState SAML Parameter

Also known asGHSA-69j8-prx2-vx98GO-2025-3958
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-9072.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs7th percentile — riskier than 7% of all scored CVEsHighest risk
0.00%0.23%0.45%0.68%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.10.x <= 10.10.1, 10.5.x <= 10.5.9, 10.9.x <= 10.9.4 fail to validate the redirect_to parameter, allowing an attacker to craft a malicious link that, once a user authenticates with their SAML provider, could post the user’s cookies to an attacker-controlled URL.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server≥ 10.10.0&&< 10.10.210.10.2go get github.com/mattermost/mattermost-server@v10.10.2
🐹Gogithub.com/mattermost/mattermost-server≥ 10.5.0&&< 10.5.1010.5.10go get github.com/mattermost/mattermost-server@v10.5.10
🐹Gogithub.com/mattermost/mattermost-server≥ 10.9.0&&< 10.9.510.9.5go get github.com/mattermost/mattermost-server@v10.9.5
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20250731063404-9eebaadf8f72go get github.com/mattermost/mattermost/server/v8@v8.0.0-20250731063404-9eebaadf8f72

Affected Products

1 product · 3 configurations
Application
mattermost servermattermost
≥ 10.10.0 && < 10.10.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 10.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-9072 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

Mattermost versions 10.10.x <= 10.10.1, 10.5.x <= 10.5.9, 10.9.x <= 10.9.4 fail to validate the redirect_to parameter, allowing an attacker to craft a malicious link that, once a user authenticates with their SAML provider, could post the user’s cookies to an attacker-controlled URL.
O3 Security · Impact-Aware SCA

Is CVE-2025-9072 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-9072: mattermost-server — Fixed in 10.10.2