CVE-2025-8419 — keycloak-services
MEDIUMCVE-2025-8419 is a medium-severity (CVSS 5.3) CWE-93 vulnerability in org.keycloak:keycloak-services. A fix is available for org.keycloak:keycloak-services — see the affected versions and patch details below.
Org.keycloak/keycloak-services: keycloak smtp inject vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-8419.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.keycloak:keycloak-services☕org.keycloak:keycloak-servicesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in Keycloak-services. Special characters used during e-mail registration may perform SMTP Injection and unexpectedly send short unwanted e-mails. The email is limited to 64 characters (limited local part of the email), so the attack is limited to very shorts emails (subject and little data, the example is 60 chars). This flaw's only direct consequence is an unsolicited email being sent from the Keycloak server. However, this action could be a precursor for more sophisticated attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.keycloak:keycloak-services | all versions | 26.2.8org.keycloak:keycloak-services:26.2.8 |
| ☕Maven | org.keycloak:keycloak-services | ≥ 26.3.0&&< 26.3.3 | 26.3.3org.keycloak:keycloak-services:26.3.3 |
Affected Products
keycloakredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-services, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.keycloak:keycloak-services to 26.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-8419 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A moderate-severity SMTP injection flaw was found in the Red Hat Build of Keycloak (RHBK) keycloak-services component (CVSS 3.1 score 5.3, AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N). During email registration, an unauthenticated remote attacker can supply an email address containing specially crafted UTF-8 characters whose…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat build of Keycloak 26.0 | see advisory | RHSA-2025:15336 |
| Red Hat build of Keycloak 26.0 | rhbk/keycloak-operator-bundle:26.0.15-1 | RHSA-2025:15337 |
| Red Hat build of Keycloak 26.2 | see advisory | RHSA-2025:15339 |
| Red Hat build of Keycloak 26.2 | rhbk/keycloak-operator-bundle:26.2.8-1 | RHSA-2025:15338 |
Frequently Asked Questions
Is CVE-2025-8419 in your dependencies?
Find it across Maven, including transitive dependencies.