CVE-2025-7339 is a low-severity (CVSS 3.4) CWE-241 vulnerability in on-headers. A fix is available for on-headers — see the affected versions and patch details below.
on-headers vulnerable to http response header manipulation
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-7339.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
on-headersnpmDescription
on-headers is a node.js middleware for listening to when a response writes headers. A bug in on-headers versions <1.1.0 may result in response headers being inadvertently modified when an array is passed to response.writeHead(). Users should upgrade to version 1.1.0 to receive a patch. Uses are strongly encouraged to upgrade to 1.1.0, but this issue can be worked around by passing an object to response.writeHead() rather than an array.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | on-headers | all versions | 1.1.0npm install on-headers@1.1.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for on-headers, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update on-headers to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-7339 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Users may work around this issue by passing an object rather than an array to the `response.writeHead()` function.Source: Red Hat security advisory for CVE-2025-7339 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Openshift Data Foundation 4.20 | odf4/cephcsi-rhel9:v4.20-1761848902 | RHSA-2025:21704 |
Frequently Asked Questions
Is CVE-2025-7339 in your dependencies?
Find it across npm, including transitive dependencies.