NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2025-7195 — operator-sdk

MEDIUM

CVE-2025-7195 is a medium-severity (CVSS 6.4) Incorrect Default Permissions vulnerability in github.com/operator-framework/operator-sdk. A fix is available for github.com/operator-framework/operator-sdk — see the affected versions and patch details below.

Operator-sdk: privilege escalation due to incorrect permissions of /etc/passwd

Also known asGHSA-856v-8qm2-9wjvGO-2025-3852
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-7195.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs16th percentile — riskier than 16% of all scored CVEsHighest risk
0.00%0.25%0.50%0.74%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/operator-framework/operator-sdk

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Early versions of Operator-SDK provided an insecure method to allow operator containers to run in environments that used a random UID. Operator-SDK before 0.15.2 provided a script, user_setup, which modifies the permissions of the /etc/passwd file to 664 during build time. Developers who used Operator-SDK before 0.15.2 to scaffold their operator may still be impacted by this if the insecure user_setup script is still being used to build new container images.

In affected images, the /etc/passwd file is created during build time with group-writable permissions and a group ownership of root (gid=0). An attacker who can execute commands within an affected container, even as a non-root user, may be able to leverage their membership in the root group to modify the /etc/passwd file. This could allow the attacker to add a new user with any arbitrary UID, including UID 0, leading to full root privileges within the container.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/operator-framework/operator-sdkall versions0.15.2go get github.com/operator-framework/operator-sdk@v0.15.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/operator-framework/operator-sdk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/operator-framework/operator-sdk to 0.15.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-7195 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Product Security has rated this vulnerability as moderate severity for affected products which run on OpenShift. The vulnerability allows for potential privilege escalation within a container, but OpenShift's default, multi-layered security posture effectively mitigates this risk. The primary controls include…

Workaround published by Red Hat
In Red Hat OpenShift Container Platform, the following default configurations reduce the impact of this vulnerability. Security Context Constraints (SCCs): The default SCC, Restricted-v2, applies several crucial security settings to containers. Capabilities: drop: ALL removes all Linux capabilities, including SETUID and SETGID. This prevents a process from changing its user or group ID, a common step in privilege escalation attacks. The SETUID and SETGID capabilities can also be dropped explicitly if other capabilities are still required. allowPrivilegeEscalation: false ensures that a process cannot gain more privileges than its parent process. This blocks attempts by a compromised…
Source: Red Hat security advisory for CVE-2025-7195 (CC BY 4.0)
ProductFixed inAdvisory
RHEL-9-CNV-4.17container-native-virtualization/cluster-network-addons-operator-rhel9:v4.17.39-2RHEA-2026:0129
RHEL-9-CNV-4.18container-native-virtualization/cluster-network-addons-operator-rhel9:v4.18.25-3RHEA-2025:23478
RHEL-9-CNV-4.20container-native-virtualization/cluster-network-addons-operator-rhel9:v4.20.3-3RHEA-2025:23406
multicluster engine for Kubernetes 2.6multicluster-engine/addon-manager-rhel9:v2.6RHSA-2025:23528
multicluster engine for Kubernetes 2.7multicluster-engine/addon-manager-rhel9:v2.7RHSA-2025:19958
multicluster engine for Kubernetes 2.7multicluster-engine/addon-manager-rhel9:v2.7RHSA-2025:22683
multicluster engine for Kubernetes 2.8multicluster-engine/addon-manager-rhel9:1765872406RHSA-2026:0722
multicluster engine for Kubernetes 2.9multicluster-engine/addon-manager-rhel9:v2.9RHSA-2025:19332

Frequently Asked Questions

Early versions of Operator-SDK provided an insecure method to allow operator containers to run in environments that used a random UID. Operator-SDK before 0.15.2 provided a script, user_setup, which modifies the permissions of the /etc/passwd file to 664 during build time. Developers who used Operator-SDK before 0.15.2 to scaffold their operator may still be impacted by this if the insecure user_setup script is still being used to build new container images. In affected images, the /etc/passwd file is created during build time with group-writable permissions and a group ownership of root (gi
O3 Security · Impact-Aware SCA

Is CVE-2025-7195 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-7195: operator-sdk — Fixed in 0.15.2