CVE-2025-71379 — vllm
Fix: vllm-project/vllm#18454CVE-2025-71379 is a CWE-1333 vulnerability in vllm. A fix is available for vllm — see the affected versions and patch details below.
vllm - Regular Expression Denial of Service in Multiple Components
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-71379.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
vllmReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A recent review identified several regular expressions in the vllm codebase that are susceptible to Regular Expression Denial of Service (ReDoS) attacks. These patterns, if fed with crafted or malicious input, may cause severe performance degradation due to catastrophic backtracking.
1. vllm/lora/utils.py Line 173
https://github.com/vllm-project/vllm/blob/2858830c39da0ae153bc1328dbba7680f5fbebe1/vllm/lora/utils.py#L173 Risk Description:
- The regex
r"\((.*?)\)\$?$"matches content inside parentheses. If input such as((((a|)+)+)+)is passed in, it can cause catastrophic backtracking, leading to a ReDoS vulnerability. - Using
.*?(non-greedy match) inside group parentheses can be highly sensitive to input length and nesting complexity.
Remediation Suggestions:
- Limit the input string length.
- Use a non-recursive matching approach, or write a regex with stricter content constraints.
- Consider using possessive quantifiers or atomic groups (not supported in Python yet), or split and process before regex matching.
2. vllm/entrypoints/openai/tool_parsers/phi4mini_tool_parser.py Line 52
Risk Description:
- The regex
r'functools\[(.*?)\]'uses.*?to match content inside brackets, together withre.DOTALL. If the input contains a large number of nested or crafted brackets, it can cause backtracking and ReDoS.
Remediation Suggestions:
- Limit the length of
model_output. - Use a stricter, non-greedy pattern (avoid matching across extraneous nesting).
- Prefer
re.finditer()and enforce a length constraint on each match.
3. vllm/entrypoints/openai/serving_chat.py Line 351
Risk Description:
- The regex
r'.*"parameters":\s*(.*)'can trigger backtracking ifcurrent_textis very long and contains repeated structures. - Especially when processing strings from unknown sources,
.*matching any content is high risk.
Remediation Suggestions:
- Use a more specific pattern (e.g., via JSON parsing).
- Impose limits on
current_textlength. - Avoid using
.*to capture large blocks of text; prefer structured parsing when possible.
4. benchmarks/benchmark_serving_structured_output.py Line 650
Risk Description:
- The regex
r'\{.*\}'is used to extract JSON inside curly braces. If theactualstring is very long with unbalanced braces, it can cause backtracking, leading to a ReDoS vulnerability. - Although this is used for benchmark correctness checking, it should still handle abnormal inputs carefully.
Remediation Suggestions:
- Limit the length of
actual. - Prefer stepwise search for
{and}or use a robust JSON extraction tool. - Recommend first locating the range with simple string search, then applying regex.
Fix
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | vllm | ≥ 0.6.3&&< 0.9.0 | 0.9.0pip install --upgrade 'vllm==0.9.0' |
Affected Products
vllmvllmDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vllm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vllm to 0.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-71379 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat rates this issue as having Low impact for Red Hat AI products. Shipped vLLM versions in Red Hat OpenShift AI, Red Hat AI Inference Server, and Red Hat Enterprise Linux AI do not include the vulnerable regular expression code paths.
No mitigation required for unaffected versions.Source: Red Hat security advisory for CVE-2025-71379 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-71379 in your dependencies?
Find it across PyPI, including transitive dependencies.