CVE-2025-69228 — aiohttp
Fix: aio-libs/aiohttp@b7dbd35CVE-2025-69228 is a CWE-770 vulnerability in aiohttp. A fix is available for aiohttp — see the affected versions and patch details below.
AIOHTTP vulnerable to denial of service through large payloads
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-69228.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
aiohttpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Versions 3.13.2 and below allow a request to be crafted in such a way that an AIOHTTP server's memory fills up uncontrollably during processing. If an application includes a handler that uses the Request.post() method, an attacker may be able to freeze the server by exhausting the memory. This issue is fixed in version 3.13.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aiohttp | all versions | 3.13.3pip install --upgrade 'aiohttp==3.13.3' |
Affected Products
aiohttpaiohttpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aiohttp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aiohttp to 3.13.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-69228 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated Moderate for Red Hat products. A flaw in aiohttp allows a remote attacker to cause a Denial of Service (DoS) by sending a specially crafted POST request to an aiohttp server that utilizes the `Request.post()` method. This can lead to uncontrolled memory consumption, freezing the server and…
No mitigation is currently available that meets Red Hat Product Security’s standards for usability, deployment, applicability, or stability.Source: Red Hat security advisory for CVE-2025-69228 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AI Inference Server 3.2 | rhaiis/vllm-cuda-rhel9:1774351144 | RHSA-2026:5809 |
| Red Hat AI Inference Server 3.2 | rhaiis/model-opt-cuda-rhel9:1774547384 | RHSA-2026:6761 |
| Red Hat AI Inference Server 3.2 | rhaiis/vllm-rocm-rhel9:1775252598 | RHSA-2026:6762 |
| Red Hat Ansible Automation Platform 2.18 | ansible-automation-platform/ee-minimal-rhel8:1786971288 | RHSA-2026:55853 |
| Red Hat Ansible Automation Platform 2.18 | ansible-automation-platform/ee-minimal-rhel9:1786942232 | RHSA-2026:55852 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-26/lightspeed-chatbot-rhel9:1777398576 | RHSA-2026:13545 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-26/lightspeed-rhel9:1787244079 | RHSA-2026:59155 |
| Red Hat Migration Toolkit 1.8 | rhmtc/openshift-migration-hook-runner-rhel8:1783931722 | RHSA-2026:41928 |
Frequently Asked Questions
Is CVE-2025-69228 in your dependencies?
Find it across PyPI, including transitive dependencies.