CVE-2025-68113 is a medium-severity (CVSS 6.5) CWE-115 vulnerability in github.com/altcha-org/altcha-lib-go. A fix is available for github.com/altcha-org/altcha-lib-go — see the affected versions and patch details below.
ALTCHA Proof-of-Work Vulnerable to Challenge Splicing and Replay
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-68113.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/altcha-org/altcha-lib-go💧altcha☕org.altcha:altcha📦altcha-lib🐘altcha-org/altcha🐍altcha💎altchaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go, Hex, Maven packages — download data is not available via public APIs for these ecosystems.
Description
ALTCHA is privacy-first software for captcha and bot protection. A cryptographic semantic binding flaw in ALTCHA libraries allows challenge payload splicing, which may enable replay attacks. The HMAC signature does not unambiguously bind challenge parameters to the nonce, allowing an attacker to reinterpret a valid proof-of-work submission with a modified expiration value. This may allow previously solved challenges to be reused beyond their intended lifetime, depending on server-side replay handling and deployment assumptions. The vulnerability primarily impacts abuse-prevention mechanisms such as rate limiting and bot mitigation. It does not directly affect data confidentiality or integrity. This issue has been addressed by enforcing explicit semantic separation between challenge parameters and the nonce during HMAC computation. Users are advised to upgrade to patched versions, which include version 1.0.0 of the altcha Golang package, version 1.0.0 of the altcha Rubygem, version 1.0.0 of the altcha pip package, version 1.0.0 of the altcha Erlang package, version 1.4.1 of the altcha-lib npm package, version 1.3.1 of the altcha-org/altcha Composer package, and version 1.3.0 of the org.altcha:altcha Maven package. As a mitigation, implementations may append a delimiter to the end of the salt value prior to HMAC computation (for example, <salt>?expires=<time>&). This prevents ambiguity between parameters and the nonce and is backward-compatible with existing implementations, as the delimiter is treated as a standard URL parameter separator.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/altcha-org/altcha-lib-go | all versions | 1.0.0go get github.com/altcha-org/altcha-lib-go@v1.0.0 |
| 💧Hex | altcha | all versions | 1.0.0mix deps.update altcha |
| ☕Maven | org.altcha:altcha | all versions | 1.3.0org.altcha:altcha:1.3.0 |
| 📦npm | altcha-lib | all versions | 1.4.1npm install altcha-lib@1.4.1 |
| 🐘Packagist | altcha-org/altcha | all versions | 1.3.1composer require altcha-org/altcha:^1.3.1 |
| 🐍PyPI | altcha | all versions | 1.0.0pip install --upgrade 'altcha==1.0.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/altcha-org/altcha-lib-go, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/altcha-org/altcha-lib-go to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-68113 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-68113 in your dependencies?
Find it across Go, Hex, Maven, including transitive dependencies.