NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CVE-2025-67852 — moodle

LOWFix: moodle/moodle@fa1624c

CVE-2025-67852 is a low-severity (CVSS 3.5) Open Redirect vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle: moodle: open redirect vulnerability in oauth login flow allows redirection to malicious sites.

Also known asBIT-moodle-2025-67852GHSA-qv78-6gpp-hm68
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-67852.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs18th percentile — riskier than 18% of all scored CVEsHighest risk
0.00%0.25%0.51%0.76%0.0%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Moodle. An open redirect vulnerability in the OAuth login flow allows a remote attacker to redirect users to attacker-controlled pages after they have successfully authenticated. This occurs due to insufficient validation of redirect parameters, which could lead to phishing attacks or information disclosure.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodleall versions4.1.22composer require moodle/moodle:^4.1.22
🐘Packagistmoodle/moodle≥ 4.4.0-beta&&< 4.4.124.4.12composer require moodle/moodle:^4.4.12
🐘Packagistmoodle/moodle≥ 4.5.0-beta&&< 4.5.84.5.8composer require moodle/moodle:^4.5.8
🐘Packagistmoodle/moodle≥ 5.0.0-beta&&< 5.0.45.0.4composer require moodle/moodle:^5.0.4
🐘Packagistmoodle/moodle≥ 5.1.0-beta&&< 5.1.15.1.1composer require moodle/moodle:^5.1.1

Affected Products

1 product · 5 configurations
Application
moodlemoodle
≥ 5.0.0 && < 5.0.4
1 version
5.1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.1.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-67852 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

A flaw was found in Moodle. An open redirect vulnerability in the OAuth login flow allows a remote attacker to redirect users to attacker-controlled pages after they have successfully authenticated. This occurs due to insufficient validation of redirect parameters, which could lead to phishing attacks or information disclosure.
O3 Security · Impact-Aware SCA

Is CVE-2025-67852 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-67852: moodle Info Disclosure — Fixed in 4.1.22