CVE-2025-67851 is a medium-severity (CVSS 6.1) CWE-1236 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle: moodle: formula injection allows arbitrary formula execution via unescaped data export
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-67851.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in moodle. This formula injection vulnerability occurs when data fields are exported without proper escaping. A remote attacker could exploit this by providing malicious data that, when exported and opened in a spreadsheet, allows arbitrary formulas to execute. This can lead to compromised data integrity and unintended operations within the spreadsheet.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | all versions | 4.1.22composer require moodle/moodle:^4.1.22 |
| 🐘Packagist | moodle/moodle | ≥ 4.4.0-beta&&< 4.4.12 | 4.4.12composer require moodle/moodle:^4.4.12 |
| 🐘Packagist | moodle/moodle | ≥ 4.5.0-beta&&< 4.5.8 | 4.5.8composer require moodle/moodle:^4.5.8 |
| 🐘Packagist | moodle/moodle | ≥ 5.0.0-beta&&< 5.0.4 | 5.0.4composer require moodle/moodle:^5.0.4 |
| 🐘Packagist | moodle/moodle | ≥ 5.1.0-beta&&< 5.1.1 | 5.1.1composer require moodle/moodle:^5.1.1 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.1.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-67851 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-67851 in your dependencies?
Find it across Packagist, including transitive dependencies.