NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2025-67731 — servify-express

Fix: Aarondoran/servify-express@8dff7f5

CVE-2025-67731 is a Uncontrolled Resource Consumption vulnerability in servify-express. A fix is available for servify-express — see the affected versions and patch details below.

Servify Express does not enforce rate limiting when parsing JSON

Also known asGHSA-qgc4-8p88-4w7m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-67731.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs35th percentile — riskier than 35% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
servify-expressnpm
21downloads / week

Description

Impact

The Express server uses express.json() without a size limit, which can allow attackers to send extremely large request bodies. This may lead to excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser without limits and exposed to untrusted clients is affected.

Patches

This issue is not a flaw in Express itself but in configuration. Users should set a request-size limit when enabling the JSON body parser. For example: app.use(express.json({ limit: "100kb" }));

Workarounds

Users can mitigate the issue without upgrading by:

  • Adding a limit option to the JSON parser
  • Implementing rate limiting at the application or reverse-proxy level
  • Rejecting unusually large requests before parsing
  • Using a reverse proxy (such as NGINX) to enforce maximum request body sizes

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmservify-expressall versions1.2npm install servify-express@1.2

Affected Products

1 product · 1 configurations
Application
servify expressservify-express.js
< 1.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for servify-express, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update servify-express to 1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-67731 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact The Express server uses `express.json()` without a size limit, which can allow attackers to send extremely large request bodies. This may lead to excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser without limits and exposed to untrusted clients is affected. ### Patches This issue is not a flaw in Express itself but in configuration. Users should set a request-size limit when enabling the JSON body parser. For example: `app.use(express.json({ limit: "100kb" }));` ### Workarounds Users can m
O3 Security · Impact-Aware SCA

Is CVE-2025-67731 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-67731: servify-express DoS — Fixed in 1.2