CVE-2025-67509 is a high-severity (CVSS 8.2) Code Injection vulnerability in neuron-core/neuron-ai. A fix is available for neuron-core/neuron-ai — see the affected versions and patch details below.
MySQLSelectTool Read-Only Bypass via SELECT INTO OUTFILE Allows Arbitrary File Write
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-67509.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
neuron-core/neuron-aiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
MySQLSelectTool is intended to be a read-only SQL tool (e.g., for LLM agent querying). However, validation based on the first keyword (e.g., SELECT) and a forbidden-keyword list does not block file-writing constructs such as INTO OUTFILE / INTO DUMPFILE.
As a result, an attacker who can influence the tool input (e.g., prompt injection through a public agent endpoint) may be able to write arbitrary content to files on the DB server.
If the MySQL/MariaDB account has the FILE privilege and server configuration permits writes to a useful location (e.g., a web-accessible directory), the impact can escalate to remote code execution on the application host (for example, by writing a PHP web shell).
Who is impacted: Deployments that expose an agent using MySQLSelectTool to untrusted input and run with overly-permissive DB privileges/configuration.
Patches
Not patched in: 2.8.11
Fixed in: 2.8.12
Recommended fix direction:
-
Explicitly reject queries containing:
INTO,OUTFILE,DUMPFILE,LOAD_FILE, and other file/IO-related functions/clauses. -
Prefer AST-based validation (SQL parser) over keyword checks.
-
Constrain allowed tables/columns and disallow multi-statements.
Workarounds
If you cannot upgrade immediately:
-
Remove/disable
MySQLSelectToolfor any agent reachable from untrusted input. -
Ensure DB account used by the tool does not have
FILEprivilege. -
Ensure
secure_file_privis set to a directory that is not web-accessible (or restrict it tightly). -
Add a defensive query filter at the application layer rejecting
INTO OUTFILE,INTO DUMPFILE,LOAD_FILE,;(multi-statements), and suspicious comment patterns.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | neuron-core/neuron-ai | all versions | 2.8.12composer require neuron-core/neuron-ai:^2.8.12 |
Affected Products
neuronneuron-aiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neuron-core/neuron-ai, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update neuron-core/neuron-ai to 2.8.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-67509 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2025-67509 in your dependencies?
Find it across Packagist, including transitive dependencies.