CVE-2025-66627 is a high-severity (CVSS 8.4) Use After Free vulnerability in wasmi. A fix is available for wasmi — see the affected versions and patch details below.
Wasmi's Linear Memory has a Critical Use After Free Vulnerability
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-66627.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
wasmi🦀wasmi🦀wasmi🦀wasmiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A use-after-free vulnerability has been discovered in the linear memory implementation of Wasmi. This issue can be triggered by a WebAssembly module under certain memory growth conditions, potentially leading to memory corruption, information disclosure, or code execution.
Impact
- Confidentiality: High – attacker-controlled memory reads possible.
- Integrity: High – memory corruption may allow arbitrary writes.
- Availability: High – interpreter crashes possible.
Affected Versions
Wasmi v0.41.0 through Wasmi v1.0.0.
Workarounds
- Upgrade to the latest patched version of Wasmi.
- Consider limiting the maximum linear memory sizes where feasible.
Credits
This vulnerability was discovered by Robert T. Morris (RTM).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | wasmi | ≥ 0.41.0&&< 0.41.2 | 0.41.2cargo update -p wasmi --precise 0.41.2 |
| 🦀crates.io | wasmi | ≥ 0.42.0&&< 0.47.1 | 0.47.1cargo update -p wasmi --precise 0.47.1 |
| 🦀crates.io | wasmi | ≥ 0.50.0&&< 0.51.3 | 0.51.3cargo update -p wasmi --precise 0.51.3 |
| 🦀crates.io | wasmi | ≥ 1.0.0&&< 1.0.1 | 1.0.1cargo update -p wasmi --precise 1.0.1 |
Affected Products
wasmiwasmi-labsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wasmi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update wasmi to 0.41.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-66627 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2025-66627 in your dependencies?
Find it across crates.io, including transitive dependencies.