CVE-2025-66418 — urllib3
Fix: urllib3/urllib3@24d7b67CVE-2025-66418 is a CWE-770 vulnerability in urllib3. A fix is available for urllib3 — see the affected versions and patch details below.
urllib3 allows an unbounded number of links in the decompression chain
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-66418.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
urllib3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
urllib3 supports chained HTTP encoding algorithms for response content according to RFC 9110 (e.g., Content-Encoding: gzip, zstd).
However, the number of links in the decompression chain was unbounded allowing a malicious server to insert a virtually unlimited number of compression steps leading to high CPU usage and massive memory allocation for the decompressed data.
Affected usages
Applications and libraries using urllib3 version 2.5.0 and earlier for HTTP requests to untrusted sources unless they disable content decoding explicitly.
Remediation
Upgrade to at least urllib3 v2.6.0 in which the library limits the number of links to 5.
If upgrading is not immediately possible, use preload_content=False and ensure that resp.headers["content-encoding"] contains a safe number of encodings before reading the response content.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | urllib3 | ≥ 1.24&&< 2.6.0 | 2.6.0pip install --upgrade 'urllib3==2.6.0' |
Affected Products
urllib3pythonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for urllib3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update urllib3 to 2.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-66418 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This Important impact denial of service vulnerability in the urllib3 HTTP client library allows uncontrolled memory consumption when decompressing highly compressed HTTP responses. Due to the lack of an overall decompression size limit in the Streaming API, a malicious server can exhaust client memory, leading to a…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2025-66418 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | python-urllib3-0:1.26.19-2.el10_1.1 | RHSA-2026:1086 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | python-urllib3-0:1.26.19-2.el10_0.1 | RHSA-2026:1726 |
| Red Hat Enterprise Linux 7 Extended Lifecycle Support | resource-agents-0:4.1.1-61.el7_9.21 | RHSA-2026:1336 |
| Red Hat Enterprise Linux 7 Extended Lifecycle Support | python-s3transfer-0:0.1.13-1.el7_9.3 | RHSA-2026:1337 |
| Red Hat Enterprise Linux 8 | python3.11-urllib3-0:1.26.12-6.el8_10 | RHSA-2026:1224 |
| Red Hat Enterprise Linux 8 | python3.12-urllib3-0:1.26.19-2.el8_10 | RHSA-2026:1226 |
| Red Hat Enterprise Linux 8 | fence-agents-0:4.2.1-129.el8_10.20 | RHSA-2026:1240 |
| Red Hat Enterprise Linux 8 | resource-agents-0:4.9.0-54.el8_10.27 | RHSA-2026:1241 |
Frequently Asked Questions
Is CVE-2025-66418 in your dependencies?
Find it across PyPI, including transitive dependencies.