CVE-2025-66402 — misskey-js
Fix: misskey-dev/misskey@dc77d59CVE-2025-66402 is a CWE-862 vulnerability in misskey-js. A fix is available for misskey-js — see the affected versions and patch details below.
misskey.js's export data contains private post data
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-66402.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
misskey-jsnpmDescription
Summary
After adding private posts (followers, direct) that you do not have permission to view to your favorites or clips, you can export them to view the contents of the private posts.
PoC
- Create an account (X) for testing and an account (Y) for private posts on the same server.
- Send appropriate content from Y using "Follow"
- Send appropriate content to any user using "Nominate" from Y
- Obtain the URLs for the two posts above using Y's account.
- Query the URLs for the two posts using X and add them to your favorites or clips.
- Export your favorites or clips using X.
- Check the exported data.
Note: Verified in v2025.11.1
Impact
This could allow an attacker to view the contents of private posts. If you have pinned private posts, this could be a real problem, as the ID of the private post can be obtained by viewing the user page on the original server.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | misskey-js | ≥ 13.0.0-beta.16&&< 2025.12.0 | 2025.12.0npm install misskey-js@2025.12.0 |
Affected Products
misskeymisskeyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for misskey-js, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update misskey-js to 2025.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-66402 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-66402 in your dependencies?
Find it across npm, including transitive dependencies.