CVE-2025-66303 is a medium-severity (CVSS 4.9) Uncontrolled Resource Consumption vulnerability in getgrav/grav. A fix is available for getgrav/grav — see the affected versions and patch details below.
Grav is vulnerable to a DOS on the admin panel
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-66303.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
getgrav/gravReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
DOS on the admin panel
Severity Rating: Medium
Vector: Denial Of Service
CVE: XXX
CWE: 400 - Uncontrolled Resource Consumption
CVSS Score: 4.9
CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Analysis
A Denial of Service (DoS) vulnerability has been identified in the application related to the handling of scheduled_at parameters. Specifically, the application fails to properly sanitize input for cron expressions. By manipulating the scheduled_at parameter with a malicious input, such as a single quote, the application admin panel becomes non-functional, causing significant disruptions to administrative operations.
The only way to recover from this issue is to manually access the host server and modify the backup.yaml file to correct the corrupted cron expression
Proof of Concept
-
Change the value of
scheduled_atparameter to'as shown in the following figures at thehttp://127.0.0.1/admin/toolsendpoint, and observe the response in the second figure:Figure: Http request on tool endpoint
Figure: Http response on tool endpoint
-
When trying to access the admin panel, the panel is broken as shown in the following figure. Additionally, the value change is reflected in the
backup.yamlfile, as shown in the second figure:Figure: Error message view
Figure: Backup.yaml file
Workarounds
No workaround is currently known
Timeline
2024-07-24 Issue identified
2024-09-27 Vendor contacted
About X41 D-Sec GmbH
X41 is an expert provider for application security services. Having extensive industry experience and expertise in the area of information security, a strong core security team of world class security experts enables X41 to perform premium security services.
Fields of expertise in the area of application security are security centered code reviews, binary reverse engineering and vulnerability discovery. Custom research and IT security consulting and support services are core competencies of X41.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | getgrav/grav | all versions | 1.8.0-beta.27composer require getgrav/grav:^1.8.0-beta.27 |
Affected Products
gravgetgravDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getgrav/grav, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update getgrav/grav to 1.8.0-beta.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-66303 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2025-66303 in your dependencies?
Find it across Packagist, including transitive dependencies.