CVE-2025-66033 is a medium-severity (CVSS 5.3) CWE-401 vulnerability in com.okta.sdk:okta-sdk-root. A fix is available for com.okta.sdk:okta-sdk-root — see the affected versions and patch details below.
Improper Memory Cleanup in the Okta Java SDK
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-66033.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.okta.sdk:okta-sdk-rootReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Description
In the Okta Java SDK, specific multithreaded implementations may encounter memory issues as threads are not properly cleaned up after requests are completed. Over time, this can degrade performance and availability in long-running applications and may result in a denial-of-service condition under sustained load.
Affected product and versions
You may be affected by this vulnerability if you meet the following preconditions:
- Using the Okta Java SDK between versions 21.0.0 and 24.0.0, and
- Implementing a long-running application using the ApiClient in a multi-threaded manner.
Resolution
Upgrade Okta/okta-sdk-java to versions 24.0.1 or greater.
Acknowledgement
Okta would like to thank Andrew Pikler (pyckle) for their discovery and responsible disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.okta.sdk:okta-sdk-root | ≥ 21.0.0&&< 24.0.1 | 24.0.1com.okta.sdk:okta-sdk-root:24.0.1 |
Affected Products
java management sdkoktaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.okta.sdk:okta-sdk-root, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.okta.sdk:okta-sdk-root to 24.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-66033 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-66033 in your dependencies?
Find it across Maven, including transitive dependencies.