CVE-2025-6514 is a critical-severity (CVSS 9.6) OS Command Injection vulnerability in mcp-remote. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mcp-remote — see the affected versions and patch details below.
OS command injection in mcp-remote when connecting to untrusted MCP servers
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-6514.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
mcp-remotenpmDescription
mcp-remote is exposed to OS command injection when connecting to untrusted MCP servers due to crafted input from the authorization_endpoint response URL
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | mcp-remote | ≥ 0.0.5&&< 0.1.16 | 0.1.16npm install mcp-remote@0.1.16 |
Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mcp-remote, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mcp-remote to 0.1.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-6514 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2025-6514 in your dependencies?
Find it across npm, including transitive dependencies.