CVE-2025-64170 is a low-severity (CVSS 3.8) CWE-549 vulnerability in sudo-rs. A fix is available for sudo-rs — see the affected versions and patch details below.
sudo-rs: Partial password reveal is possible after timeout
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-64170.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sudo-rsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Summary
If a user begins entering a password but does not press return for an extended period, a password timeout may occur. When this happens, the keystrokes that were entered are echoed back to the console.
Example
Using sudo-rs:
geiger@cerberus:~$ sudo -s
[sudo: authenticate] Password: sudo-rs: timed out
geiger@cerberus:~$ testtesttest
"testtesttest" was entered at the password prompt but not confirmed by pressing return and then waiting for the timeout.
Impact
This could reveal partial password information, possibly exposing history files when not carefully handled by the user and on screen, usable for Social Engineering or Pass-By attacks.
Versions affected
Passwords timeouts were added in sudo-rs 0.2.7 (with a default set to 5 minutes).
Credits
This issue was discovered and reported by @DevLaTron.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | sudo-rs | ≥ 0.2.7&&< 0.2.10 | 0.2.10cargo update -p sudo-rs --precise 0.2.10 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sudo-rs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sudo-rs to 0.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-64170 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-64170 in your dependencies?
Find it across crates.io, including transitive dependencies.