CVE-2025-62370 is a high-severity (CVSS 7.5) CWE-248 vulnerability in alloy-dyn-abi. A fix is available for alloy-dyn-abi — see the affected versions and patch details below.
Alloy Core has a DoS vulnerability on `alloy_dyn_abi::TypedData` hashing
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-62370.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
alloy-dyn-abi🦀alloy-dyn-abiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
An uncaught panic triggered by malformed input to alloy_dyn_abi::TypedData could lead to a denial-of-service (DoS) via eip712_signing_hash().
Software with high availability requirements such as network services may be particularly impacted. If in use, external auto-restarting mechanisms can partially mitigate the availability issues unless repeated attacks are possible.
Patches
The vulnerability was patched by adding a check to ensure the element is not empty before accessing its first element; an error is returned if it is empty. The fix is included in version v1.4.1 and backported to v0.8.26.
Workarounds
There is no known workaround that mitigates the vulnerability. Upgrading to a patched version is the recommended course of action.
Reported by
Christian Reitter & Zeke Mostov from Turnkey
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | alloy-dyn-abi | all versions | 0.8.26cargo update -p alloy-dyn-abi --precise 0.8.26 |
| 🦀crates.io | alloy-dyn-abi | ≥ 1.0.0&&< 1.4.1 | 1.4.1cargo update -p alloy-dyn-abi --precise 1.4.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for alloy-dyn-abi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update alloy-dyn-abi to 0.8.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-62370 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2025-62370 in your dependencies?
Find it across crates.io, including transitive dependencies.