NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2025-62228 — flink-cdc-pipeline-connec…

Fix: apache/flink-cdc#4123

CVE-2025-62228 is a SQL Injection vulnerability in org.apache.flink:flink-cdc-pipeline-connectors. A fix is available for org.apache.flink:flink-cdc-pipeline-connectors — see the affected versions and patch details below.

Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers

Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-62228.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.32%0.64%0.96%0.0%0.5%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

5 pkgs affected
☕org.apache.flink:flink-cdc-pipeline-connectors☕org.apache.flink:flink-connector-oracle-cdc☕org.apache.flink:flink-connector-db2-cdc☕org.apache.flink:flink-connector-sqlserver-cdc☕org.apache.flink:flink-connector-mysql-cdc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.flink:flink-cdc-pipeline-connectors≥ 3.0.0&&< 3.5.03.5.0org.apache.flink:flink-cdc-pipeline-connectors:3.5.0
☕Mavenorg.apache.flink:flink-connector-oracle-cdc≥ 3.0.0&&< 3.5.03.5.0org.apache.flink:flink-connector-oracle-cdc:3.5.0
☕Mavenorg.apache.flink:flink-connector-db2-cdc≥ 3.0.0&&< 3.5.03.5.0org.apache.flink:flink-connector-db2-cdc:3.5.0
☕Mavenorg.apache.flink:flink-connector-sqlserver-cdc≥ 3.0.0&&< 3.5.03.5.0org.apache.flink:flink-connector-sqlserver-cdc:3.5.0
☕Mavenorg.apache.flink:flink-connector-mysql-cdc≥ 3.0.0&&< 3.5.03.5.0org.apache.flink:flink-connector-mysql-cdc:3.5.0

Affected Products

1 product · 1 configurations
Application
flink cdcapache
1 version
3.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.flink:flink-cdc-pipeline-connectors, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.flink:flink-cdc-pipeline-connectors to 3.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-62228 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Apache Flink CDC version 3.0.0 to before 3.5.0 are vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, users are recommended to update Flink CDC version to 3.5.0 which address this issue.
O3 Security · Impact-Aware SCA

Is CVE-2025-62228 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-62228: flink-cdc-pipeline — Fixed in 3.5.0