CVE-2025-61668 — @plone/volto
Fix: plone/volto@58d9f82CVE-2025-61668 is a NULL Pointer Dereference vulnerability in @plone/volto. A fix is available for @plone/volto — see the affected versions and patch details below.
@plone/volto vulnerable to potential DoS by invoking specific URL by anonymous user
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-61668.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@plone/voltonpmDescription
Impact
When visiting a specific URL, an anonymous user could cause the NodeJS server part of Volto to quit with an error.
Patches
The problem has been patched and the patch has been backported to Volto major versions down until 16. It is advised to upgrade to the latest patch release of your respective current major version:
- Volto 16: 16.34.1
- Volto 17: 17.22.2
- Volto 18: 18.27.2
- Volto 19: 19.0.0-alpha6
Workarounds
Make sure your setup automatically restarts processes that quit with an error. This won't prevent a crash, but it minimises downtime.
Report
The problem was discovered by FHNW, a client of Plone provider kitconcept, who shared it with the Plone Zope Security Team ([email protected]).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @plone/volto | all versions | 16.34.1npm install @plone/volto@16.34.1 |
| 📦npm | @plone/volto | ≥ 17.0.0&&< 17.22.2 | 17.22.2npm install @plone/volto@17.22.2 |
| 📦npm | @plone/volto | ≥ 18.0.0&&< 18.27.2 | 18.27.2npm install @plone/volto@18.27.2 |
| 📦npm | @plone/volto | ≥ 19.0.0-alpha.1&&< 19.0.0-alpha.6 | 19.0.0-alpha.6npm install @plone/volto@19.0.0-alpha.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @plone/volto, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @plone/volto to 16.34.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-61668 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-61668 in your dependencies?
Find it across npm, including transitive dependencies.