CVE-2025-6023 — grafana
CVE-2025-6023 is a Cross-site Scripting (XSS) vulnerability in grafana. EPSS puts its 30-day exploitation probability at 57.7% (99th percentile). A fix is available for grafana — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-6023.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
grafanaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Bitnami packages — download data is not available via public APIs for these ecosystems.
Description
An open redirect vulnerability has been identified in Grafana OSS that can be exploited to achieve XSS attacks. The vulnerability was introduced in Grafana v11.5.0.
The open redirect can be chained with path traversal vulnerabilities to achieve XSS.
Fixed in versions 12.0.2+security-01, 11.6.3+security-01, 11.5.6+security-01, 11.4.6+security-01 and 11.3.8+security-01
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦Bitnami | grafana | ≥ 11.3.0&&< 11.6.3 | 11.6.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for grafana, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update grafana to 11.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-6023 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
No Red Hat products or offerings are affected by this vulnerability. As the version of grafana (9.2.10/10.2.6) shipped in this version of Red Hat Enterprise Linux is not vulnerable to this CVE. The vulnerable versions listed in the CVE posting are 12.0.x, 11.6.x, 11.5.x, 11.4.x, and 11.3.x, which are all not in Red…
Alternatively, you can block this attack by adding the default Content Security Policy configuration as suggested in the Grafana Documentation.Source: Red Hat security advisory for CVE-2025-6023 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-6023 in your dependencies?
Find it across Bitnami, including transitive dependencies.