NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2025-57749 — n8n

MEDIUMFix: n8n-io/n8n#17735

CVE-2025-57749 is a medium-severity (CVSS 6.5) CWE-59 vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

n8n has a symlink traversal vulnerability in "Read/Write File" node allows access to restricted files

Also known asGHSA-ggjm-f3g4-rwmm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-57749.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
132Kdownloads / week

Description

Impact

A symlink traversal vulnerability was discovered in the Read/Write File node in n8n. While the node attempts to restrict access to sensitive directories and files, it does not properly account for symbolic links (symlinks). An attacker with the ability to create symlinks—such as by using the Execute Command node—could exploit this to bypass the intended directory restrictions and read from or write to otherwise inaccessible paths. Users of n8n.cloud are not impacted.

Patches

Affected users should update to version 1.106.0 or later.

Workarounds

Until the patch is applied:

  • Disable or restrict access to the Execute Command node and any other nodes that allow arbitrary file system access.
  • Avoid using the Read/Write File node on untrusted paths or inputs that could be manipulated via symlinks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8nall versions1.106.0npm install n8n@1.106.0

Affected Products

1 product · 1 configurations
Application
n8nn8n
< 1.106.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 1.106.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-57749 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact A symlink traversal vulnerability was discovered in the `Read/Write File` node in n8n. While the node attempts to restrict access to sensitive directories and files, it does not properly account for symbolic links (symlinks). An attacker with the ability to create symlinks—such as by using the `Execute Command` node—could exploit this to bypass the intended directory restrictions and read from or write to otherwise inaccessible paths. Users of _n8n.cloud_ are not impacted. ### Patches Affected users should update to version 1.106.0 or later. ### Workarounds Until the patch is appl
O3 Security · Impact-Aware SCA

Is CVE-2025-57749 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-57749: n8n — Fixed in 1.106.0