NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2025-56265 — @n8n/n8n-nodes-langchain

HIGHFix: n8n-io/n8n#18148

CVE-2025-56265 is a high-severity (CVSS 8.8) Unrestricted File Upload vulnerability in @n8n/n8n-nodes-langchain. A fix is available for @n8n/n8n-nodes-langchain — see the affected versions and patch details below.

N8N's Chat Trigger component is vulnerable to XSS

Also known asGHSA-v2x8-97xq-8xrr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-56265.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs49th percentile — riskier than 49% of all scored CVEsHighest risk
0.00%0.37%0.74%1.11%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

31other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@n8n/n8n-nodes-langchainnpm
71Kdownloads / week

Description

An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3, v1.100.1, and v1.101.1 allows attackers to execute arbitrary code via uploading a crafted HTML file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@n8n/n8n-nodes-langchainall versions1.107.0npm install @n8n/n8n-nodes-langchain@1.107.0

Affected Products

1 product · 3 configurations
Application
n8nn8n
3 versions
1.95.31.100.11.101.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @n8n/n8n-nodes-langchain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @n8n/n8n-nodes-langchain to 1.107.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-56265 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

Frequently Asked Questions

An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3, v1.100.1, and v1.101.1 allows attackers to execute arbitrary code via uploading a crafted HTML file.
O3 Security · Impact-Aware SCA

Is CVE-2025-56265 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-56265: @n8n/n8n-nodes RCE — Fixed in 1.107.0