CVE-2025-55797 — FormCMS
MEDIUMCVE-2025-55797 is a medium-severity (CVSS 6.5) CWE-284 vulnerability in FormCMS. A fix is available for FormCMS — see the affected versions and patch details below.
FormCMS has an improper access control vulnerability in the /api/schemas/history/[schemaId] endpoint
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-55797.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
FormCMSReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
An improper access control vulnerability in FormCms v0.5.4 in the /api/schemas/history/[schemaId] endpoint allows unauthenticated attackers to access historical schema data if a valid schemaId is known or guessed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | FormCMS | all versions | 0.5.5dotnet add package FormCMS --version 0.5.5 |
Affected Products
formcmsformcmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for FormCMS, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update FormCMS to 0.5.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-55797 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-55797 in your dependencies?
Find it across NuGet, including transitive dependencies.