NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2025-55184 — react-server-dom-parcel

HIGH

CVE-2025-55184 is a high-severity (CVSS 7.5) Deserialization of Untrusted Data vulnerability in react-server-dom-parcel. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for react-server-dom-parcel — see the affected versions and patch details below.

Denial of Service Vulnerability in React Server Components

Also known asGHSA-2m3v-v2m8-q956
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
3 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-55184.

EPSS Exploitation Probability

via FIRST.org ↗
66.6%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
13.9%35.8%57.7%79.6%26.2%66.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

4other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
react-server-dom-parcelnpm
22Kdownloads / week
react-server-dom-turbopacknpm
53Kdownloads / week
react-server-dom-webpacknpm
2.8Mdownloads / week

Description

Impact

There is a denial of service vulnerability in React Server Components.

React recommends updating immediately.

The vulnerability exists in versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1 of:

These issues are present in the patches published last week.

Patches

Fixes were back ported to versions 19.0.2, 19.1.3, and 19.2.2.

If you are using any of the above packages please upgrade to any of the fixed versions immediately.

If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability.

References

See the blog post for more information and upgrade instructions.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
📦npmreact-server-dom-parcel≥ 19.0.0&&< 19.0.219.0.2npm install react-server-dom-parcel@19.0.2
📦npmreact-server-dom-turbopack≥ 19.0.0&&< 19.0.219.0.2npm install react-server-dom-turbopack@19.0.2
📦npmreact-server-dom-webpack≥ 19.0.0&&< 19.0.219.0.2npm install react-server-dom-webpack@19.0.2
📦npmreact-server-dom-parcel≥ 19.1.0&&< 19.1.319.1.3npm install react-server-dom-parcel@19.1.3
📦npmreact-server-dom-parcel≥ 19.2.0&&< 19.2.219.2.2npm install react-server-dom-parcel@19.2.2
📦npmreact-server-dom-turbopack≥ 19.1.0&&< 19.1.319.1.3npm install react-server-dom-turbopack@19.1.3

Affected Products

2 products · 92 configurations
Application
reactfacebook
≥ 19.2.0 && < 19.2.2
range
Application
next.jsvercel
≥ 16.0.0 && < 16.0.10
2 versions
15.6.016.1.0
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for react-server-dom-parcel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update react-server-dom-parcel to 19.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-55184 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

How to detect CVE-2025-55184

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2025-55184 -u https://target
Template
React Server Components - Denial of Service
Severity
high
Impact
Unauthenticated attackers can cause the server to hang indefinitely, resulting in denial of service and preventing legitimate requests.
Remediation
Update to the latest version beyond 19.2.1.

Template by ProjectDiscovery nuclei-templates (DhiyaneshDk), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

## Impact There is a denial of service vulnerability in React Server Components. React recommends updating immediately. The vulnerability exists in versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1 of: - [react-server-dom-webpack](https://www.npmjs.com/package/react-server-dom-webpack) - [react-server-dom-parcel](https://www.npmjs.com/package/react-server-dom-parcel) - [react-server-dom-turbopack](https://www.npmjs.com/package/react-server-dom-turbopack?activeTab=readme) These issues are present in the patches published last week. ## Patches Fixes were back ported to ver
O3 Security · Impact-Aware SCA

Is CVE-2025-55184 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-55184: react-server-dom DoS — Fixed in 19.0.2