NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2025-55073 — mattermost-server

MEDIUMFix: mattermost/mattermost@375ce22

CVE-2025-55073 is a medium-severity (CVSS 5.4) Missing Authentication vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

MS Teams plugin OAuth allows editing arbitrary posts

Also known asGHSA-ff85-qw3h-g9vpGO-2025-4129
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-55073.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs9th percentile — riskier than 9% of all scored CVEsHighest risk
0.00%0.23%0.46%0.70%0.1%0.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server≥ 10.11.0&&< 10.11.410.11.4go get github.com/mattermost/mattermost-server@v10.11.4
🐹Gogithub.com/mattermost/mattermost-server≥ 10.5.0&&< 10.5.1210.5.12go get github.com/mattermost/mattermost-server@v10.5.12
🐹Gogithub.com/mattermost/mattermost-server≥ 10.12.0&&< 10.12.110.12.1go get github.com/mattermost/mattermost-server@v10.12.1
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20250929212932-a41db04d2746go get github.com/mattermost/mattermost/server/v8@v8.0.0-20250929212932-a41db04d2746

Affected Products

1 product · 3 configurations
Application
mattermost servermattermost
≥ 10.12.0 && < 10.12.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 10.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-55073 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.
O3 Security · Impact-Aware SCA

Is CVE-2025-55073 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-55073: mattermost-server — Fixed in 10.11.4