CVE-2025-54589 is a medium-severity (CVSS 6.3) Cross-site Scripting (XSS) vulnerability in copyparty. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for copyparty — see the affected versions and patch details below.
copyparty Reflected XSS via Filter Parameter
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-54589.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
copypartyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Unauthorized reflected Cross-Site-Scripting when accessing the URL for recent uploads with the filter parameter containing JavaScript code.
Details
When accessing the recent uploads page at /?ru, users can filter the results using an input field at the top. This field appends a filter parameter to the URL, which reflects its value directly into a <script> block without proper escaping.
This vulnerability allows for reflected Cross-Site Scripting (XSS) and can be exploited against both authenticated and unauthenticated users, enabling unwanted actions in the victims browser.
PoC
A URL like this will execute alert(1):
https://127.0.0.1:3923/?ru&filter=</script><script>alert(1)</script>
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | copyparty | all versions | 1.18.7pip install --upgrade 'copyparty==1.18.7' |
Affected Products
copyparty9001Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Copyparty 1.18.6 - Reflected Cross-Site Scripting (XSS)
by Byte Reaper · Aug 3, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for copyparty, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update copyparty to 1.18.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-54589 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2025-54589
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2025-54589 -u https://target- Template
- Copyparty <=1.18.6 - Cross-Site Scripting
- Severity
- medium
- Impact
- Attackers can execute arbitrary JavaScript in victim browsers through malicious URLs containing XSS payloads in the filter parameter, potentially leading to session hijacking.
- Remediation
- Upgrade Copyparty to version 1.18.7 or later to mitigate this vulnerability.
Template by ProjectDiscovery nuclei-templates (s-cu-bot), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2025-54589 in your dependencies?
Find it across PyPI, including transitive dependencies.