NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2025-49558 — project-community-edition

MEDIUM

CVE-2025-49558 is a medium-severity (CVSS 5.9) CWE-367 vulnerability in magento/project-community-edition. A fix is available for magento/project-community-edition — see the affected versions and patch details below.

Adobe Commerce | Time-of-check Time-of-use (TOCTOU) Race Condition (CWE-367)

Also known asGHSA-wcmw-8xpp-rwfj
Published
Updated
Affected
10 pkgs
Patched
5 / 10
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-49558.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.34%0.67%1.00%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

10 pkgs affected
🐘magento/project-community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition+2 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability that could result in a security feature bypass. An attacker could exploit this vulnerability by manipulating the timing between the check of a resource's state and its use, allowing unauthorized write access. Exploitation of this issue does not require user interaction.

Affected Packages

10 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/project-community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.9-alpha1&&< 2.4.9-alpha22.4.9-alpha2composer require magento/community-edition:^2.4.9-alpha2
🐘Packagistmagento/community-edition≥ 2.4.8-beta1&&< 2.4.8-p22.4.8-p2composer require magento/community-edition:^2.4.8-p2
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p72.4.7-p7composer require magento/community-edition:^2.4.7-p7
🐘Packagistmagento/community-edition≥ 2.4.6-p1&&< 2.4.6-p122.4.6-p12composer require magento/community-edition:^2.4.6-p12
🐘Packagistmagento/community-editionall versions2.4.5-p14composer require magento/community-edition:^2.4.5-p14

Affected Products

3 products · 148 configurations
Application
commerceadobe
< 2.4.4
5 versions
2.4.42.4.52.4.62.4.72.4.8
Application
commerce b2badobe
< 1.3.3
6 versions
1.3.31.3.41.3.51.4.21.5.21.5.3
Application
magentoadobe
< 2.4.5
5 versions
2.4.52.4.62.4.72.4.82.4.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/project-community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2025-49558; check the affected-versions list above or the advisory for the patched release of magento/project-community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability that could result in a security feature bypass. An attacker could exploit this vulnerability by manipulating the timing between the check of a resource's state and its use, allowing unauthorized write access. Exploitation of this issue does not require user interaction.
O3 Security · Impact-Aware SCA

Is CVE-2025-49558 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-49558: Fixed in 2.4.9-alpha2 (Medium 5.9)