NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2025-48913 — cxf-rt-transports-jms

CRITICALFix: apache/cxf@24e50ff

CVE-2025-48913 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in org.apache.cxf:cxf-rt-transports-jms. A fix is available for org.apache.cxf:cxf-rt-transports-jms — see the affected versions and patch details below.

Apache CXF: Untrusted JMS configuration can lead to RCE

Also known asGHSA-g4px-6qhm-hqjm
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48913.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk+0.25%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.05%1.57%0.2%1.1%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.cxf:cxf-rt-transports-jms☕org.apache.cxf:cxf-rt-transports-jms☕org.apache.cxf:cxf-rt-transports-jms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

If untrusted users are allowed to configure JMS for Apache CXF, previously they could use RMI or LDAP URLs, potentially leading to code execution capabilities. This interface is now restricted to reject those protocols, removing this possibility.

Users are recommended to upgrade to versions 3.6.8, 4.0.9 or 4.1.3, which fix this issue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.cxf:cxf-rt-transports-jmsall versions3.6.8org.apache.cxf:cxf-rt-transports-jms:3.6.8
☕Mavenorg.apache.cxf:cxf-rt-transports-jms≥ 4.0.0&&< 4.0.94.0.9org.apache.cxf:cxf-rt-transports-jms:4.0.9
☕Mavenorg.apache.cxf:cxf-rt-transports-jms≥ 4.1.0&&< 4.1.34.1.3org.apache.cxf:cxf-rt-transports-jms:4.1.3

Affected Products

1 product · 3 configurations
Application
cxfapache
≥ 4.1.0 && < 4.1.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cxf:cxf-rt-transports-jms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.cxf:cxf-rt-transports-jms to 3.6.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48913 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This flaw should be considered Important because the impact goes beyond a simple denial of service or configuration misuse. By allowing untrusted users to configure JMS with RMI or LDAP URLs, attackers could achieve remote code execution by loading attacker-controlled classes or objects. Although this requires the…

Workaround published by Red Hat
To reduce risk, deployments should restrict the allowed protocols in JMS configuration to trusted and expected values only. In particular, disallow the use of rmi:// and ldap:// URLs, which could be abused for remote class loading and code execution.
Source: Red Hat security advisory for CVE-2025-48913 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7eap7-apache-cxf-0:3.1.16-6.redhat_00006.1.ep7.el7RHSA-2026:6012
Red Hat JBoss Enterprise Application Platform 7.3 EUS for RHEL 7eap7-apache-cxf-0:3.4.10-3.SP2_redhat_00003.1.el7eapRHSA-2026:6011
Red Hat JBoss Enterprise Application Platform 7.4.24org.apache.cxf/cxf-rt-transports-jms:3.5.11.SP1-redhat-00001RHSA-2026:4924
Red Hat JBoss Enterprise Application Platform 7.4 ELS on RHEL 7eap7-apache-cxf-0:3.5.11-1.SP1_redhat_00001.1.el7eapRHSA-2026:4915
Red Hat JBoss Enterprise Application Platform 7.4 ELS on RHEL 8eap7-apache-cxf-0:3.5.11-1.SP1_redhat_00001.1.el8eapRHSA-2026:4916
Red Hat JBoss Enterprise Application Platform 7.4 ELS on RHEL 9eap7-apache-cxf-0:3.5.11-1.SP1_redhat_00001.1.el9eapRHSA-2026:4917
Red Hat JBoss Enterprise Application Platform 8.0.9cxfRHSA-2025:17318
Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 8eap8-apache-cxf-0:4.0.9-5.redhat_00002.1.el8eapRHSA-2025:17317

Frequently Asked Questions

If untrusted users are allowed to configure JMS for Apache CXF, previously they could use RMI or LDAP URLs, potentially leading to code execution capabilities. This interface is now restricted to reject those protocols, removing this possibility. Users are recommended to upgrade to versions 3.6.8, 4.0.9 or 4.1.3, which fix this issue.
O3 Security · Impact-Aware SCA

Is CVE-2025-48913 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-48913: cxf-rt-transports-jms — Fixed in 3.6.8