NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 Packagist:https://packages.drupal.org/8
Not in CISA KEV

CVE-2025-48447 — lightgallery

CVE-2025-48447 is a Cross-site Scripting (XSS) vulnerability in drupal/lightgallery. A fix is available for drupal/lightgallery — see the affected versions and patch details below.

Also known asGHSA-w5px-5878-m9x4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48447.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs27th percentile — riskier than 27% of all scored CVEsHighest risk
0.00%0.28%0.56%0.83%0.3%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦drupal/lightgallery

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist:https://packages.drupal.org/8 packages — download data is not available via public APIs for these ecosystems.

Description

This module integrates Drupal with LightGallery, enabling the use of the LightGallery library with any image field or view.

The module does not adequately sanitize user input in the image field’s "alt" attribute, potentially allowing cross-site scripting (XSS) attacks when tags or scripts are inserted.

This vulnerability is partially mitigated by the requirement that an attacker must have permission to create content containing an image field configured to use the LightGallery format.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Packagist:https://packages.drupal.org/8drupal/lightgalleryall versions1.6.0

Affected Products

1 product · 1 configurations
Application
lightgallerylightgallery_project
< 1.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/lightgallery, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/lightgallery to 1.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48447 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

This module integrates Drupal with LightGallery, enabling the use of the LightGallery library with any image field or view. The module does not adequately sanitize user input in the image field’s "alt" attribute, potentially allowing cross-site scripting (XSS) attacks when tags or scripts are inserted. This vulnerability is partially mitigated by the requirement that an attacker must have permission to create content containing an image field configured to use the LightGallery format.
O3 Security · Impact-Aware SCA

Is CVE-2025-48447 in your dependencies?

Find it across Packagist:https://packages.drupal.org/8, including transitive dependencies.

CVE-2025-48447: lightgallery XSS — Fixed in 1.6.0