CVE-2025-48446 — commerce_alphabank_redire…
HIGHCVE-2025-48446 is a high-severity (CVSS 8.8) CWE-863 vulnerability in drupal/commerce_alphabank_redirect. A fix is available for drupal/commerce_alphabank_redirect — see the affected versions and patch details below.
Commerce Alphabank Redirect - Moderately critical - Access bypass - SA-CONTRIB-2025-067
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48446.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/commerce_alphabank_redirectReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect Authorization vulnerability in Drupal Commerce Alphabank Redirect allows Functionality Misuse. This issue affects Commerce Alphabank Redirect: from 0.0.0 before 1.0.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/commerce_alphabank_redirect | all versions | 1.0.3composer require drupal/commerce_alphabank_redirect:^1.0.3 |
Affected Products
commerce alphabank redirectcommerce_alphabank_redirect_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/commerce_alphabank_redirect, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/commerce_alphabank_redirect to 1.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48446 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-48446 in your dependencies?
Find it across Packagist, including transitive dependencies.