CVE-2025-48445 — commerce_eurobank_redirect
HIGHCVE-2025-48445 is a high-severity (CVSS 8.8) CWE-863 vulnerability in drupal/commerce_eurobank_redirect. A fix is available for drupal/commerce_eurobank_redirect — see the affected versions and patch details below.
Commerce Eurobank (Redirect) - Moderately critical - Access bypass - SA-CONTRIB-2025-066
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48445.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/commerce_eurobank_redirectReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect Authorization vulnerability in Drupal Commerce Eurobank (Redirect) allows Functionality Misuse. This issue affects Commerce Eurobank (Redirect): from 0.0.0 before 2.1.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/commerce_eurobank_redirect | all versions | 2.1.1composer require drupal/commerce_eurobank_redirect:^2.1.1 |
Affected Products
commerce eurobank \(redirect\)commerce_eurobank_\(redirect\)_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/commerce_eurobank_redirect, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/commerce_eurobank_redirect to 2.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48445 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-48445 in your dependencies?
Find it across Packagist, including transitive dependencies.