CVE-2025-48205 — sr-feuser-register
HIGHCVE-2025-48205 is a high-severity (CVSS 8.6) CWE-425 vulnerability in sjbr/sr-feuser-register. A fix is available for sjbr/sr-feuser-register — see the affected versions and patch details below.
The Front End User Registration extension for TYPO3 (sr_feuser_register) allows Insecure Direct Object Reference
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48205.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sjbr/sr-feuser-registerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The sr_feuser_register extension through 12.4.8 for TYPO3 allows Insecure Direct Object Reference. This allows attackers to read arbitrary files.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | sjbr/sr-feuser-register | ≥ 5.1.0&&< 12.5.0 | 12.5.0composer require sjbr/sr-feuser-register:^12.5.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sjbr/sr-feuser-register, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sjbr/sr-feuser-register to 12.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48205 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-48205 in your dependencies?
Find it across Packagist, including transitive dependencies.