CVE-2025-47937 — cms-core
LOWCVE-2025-47937 is a low-severity (CVSS 3.7) CWE-863 vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
TYPO3 Vulnerable to Information Disclosure via DBAL Restriction Handling
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-47937.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
TYPO3 is an open source, PHP based web content management system. Starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, when performing a database query involving multiple tables through the database abstraction layer (DBAL), frontend user permissions are only applied via FrontendGroupRestriction to the first table. As a result, data from additional tables included in the same query may be unintentionally exposed to unauthorized users. Users should update to TYPO3 version 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.51 | 9.5.51composer require typo3/cms-core:^9.5.51 |
| 🐘Packagist | typo3/cms-core | ≥ 10.0.0&&< 10.4.50 | 10.4.50composer require typo3/cms-core:^10.4.50 |
| 🐘Packagist | typo3/cms-core | ≥ 11.0.0&&< 11.5.44 | 11.5.44composer require typo3/cms-core:^11.5.44 |
| 🐘Packagist | typo3/cms-core | ≥ 12.0.0&&< 12.4.31 | 12.4.31composer require typo3/cms-core:^12.4.31 |
| 🐘Packagist | typo3/cms-core | ≥ 13.0.0&&< 13.4.12 | 13.4.12composer require typo3/cms-core:^13.4.12 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 9.5.51 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-47937 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-47937 in your dependencies?
Find it across Packagist, including transitive dependencies.