CVE-2025-47283 is a critical-severity (CVSS 9.9) Improper Input Validation vulnerability in github.com/gardener/gardener. A fix is available for github.com/gardener/gardener — see the affected versions and patch details below.
Bypassing project secret validation can lead to privilege escalation
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-47283.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/gardener/gardener🐹github.com/gardener/gardener🐹github.com/gardener/gardenerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A security vulnerability was discovered in Gardener that could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster(s) where their shoot clusters are managed.
Am I Vulnerable?
This CVE affects all Gardener installations no matter of the public cloud provider(s) used for the seed clusters/shoot clusters.
Affected Components
gardener/gardener
Affected Versions
- < v1.116.4
- < v1.117.5
- < v1.118.2
- < v1.119.0
Fixed Versions
- >= v1.116.4
- >= v1.117.5
- >= v1.118.2
- >= v1.119.0
How do I mitigate this vulnerability?
Update to a fixed version.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/gardener/gardener | all versions | 1.116.4go get github.com/gardener/gardener@v1.116.4 |
| 🐹Go | github.com/gardener/gardener | ≥ 1.117.0&&< 1.117.5 | 1.117.5go get github.com/gardener/gardener@v1.117.5 |
| 🐹Go | github.com/gardener/gardener | ≥ 1.118.0&&< 1.118.2 | 1.118.2go get github.com/gardener/gardener@v1.118.2 |
Affected Products
gardenergardenerDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/gardener/gardener, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/gardener/gardener to 1.116.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-47283 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-47283 in your dependencies?
Find it across Go, including transitive dependencies.