NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2025-47110 — community-edition

HIGH

CVE-2025-47110 is a high-severity (CVSS 8.4) Cross-site Scripting (XSS) vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

Also known asGHSA-j934-vjh5-vf9r
Published
Updated
Affected
8 pkgs
Patched
4 / 8
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-47110.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.18%0.53%0.88%1.23%0.7%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

8 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Scope is changed to that of other high-privileged accounts, leading to a high impact on confidentiality, integrity, and availability.

Affected Packages

8 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.4.8-beta1&&< 2.4.8-p12.4.8-p1composer require magento/community-edition:^2.4.8-p1
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p62.4.7-p6composer require magento/community-edition:^2.4.7-p6
🐘Packagistmagento/community-editionall versions2.4.5-p13composer require magento/community-edition:^2.4.5-p13
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

3 products · 104 configurations
Application
commerceadobe
5 versions
2.4.42.4.52.4.62.4.72.4.8
Application
commerce b2badobe
5 versions
1.3.31.3.41.3.51.4.21.5.2
Application
magentoadobe
4 versions
2.4.52.4.62.4.72.4.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.4.8-p1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-47110 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Scope is changed to that of other high-privileged accounts, leading to a high impact on confidentiality, integrity, and availability.
O3 Security · Impact-Aware SCA

Is CVE-2025-47110 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-47110: community XSS — Fixed in 2.4.8-p1