CVE-2025-46565 — vite
Fix: vitejs/vite@c22c43dCVE-2025-46565 is a Path Traversal vulnerability in vite. A fix is available for vite — see the affected versions and patch details below.
Vite's server.fs.deny bypassed with /. for files under project root
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-46565.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
vitenpmDescription
Summary
The contents of files in the project root that are denied by a file matching pattern can be returned to the browser.
Impact
Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected.
Only files that are under project root and are denied by a file matching pattern can be bypassed.
- Examples of file matching patterns:
.env,.env.*,*.{crt,pem},**/.env - Examples of other patterns:
**/.git/**,.git/**,.git/**/*
Details
server.fs.deny can contain patterns matching against files (by default it includes .env, .env.*, *.{crt,pem} as such patterns).
These patterns were able to bypass for files under root by using a combination of slash and dot (/.).
PoC
npm create vite@latest
cd vite-project/
cat "secret" > .env
npm install
npm run dev
curl --request-target /.env/. http://localhost:5173
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | vite | ≥ 6.3.0&&< 6.3.4 | 6.3.4npm install vite@6.3.4 |
| 📦npm | vite | ≥ 6.2.0&&< 6.2.7 | 6.2.7npm install vite@6.2.7 |
| 📦npm | vite | ≥ 6.0.0&&< 6.1.6 | 6.1.6npm install vite@6.1.6 |
| 📦npm | vite | ≥ 5.0.0&&< 5.4.19 | 5.4.19npm install vite@5.4.19 |
| 📦npm | vite | all versions | 4.5.14npm install vite@4.5.14 |
Affected Products
vitevitejsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vite, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vite to 6.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-46565 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
How to detect CVE-2025-46565
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2025-46565 -u https://target- Template
- Vite Dev Server - Information Exposure
- Severity
- medium
Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-46565 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-46565 in your dependencies?
Find it across npm, including transitive dependencies.