NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-46548 — pekko-management_2.12

MEDIUMFix: akka/akka-management#1385

CVE-2025-46548 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in org.apache.pekko:pekko-management_2.12. A fix is available for org.apache.pekko:pekko-management_2.12 — see the affected versions and patch details below.

Apache Pekko Management, Apache Pekko Management, Apache Pekko Management, Akka Management, Akka Management, Akka Management: management API basic authentication is not effective

Also known asGHSA-9qvj-rpj8-v5c8
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-46548.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.16%0.85%1.54%2.23%1.7%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕org.apache.pekko:pekko-management_2.12☕com.lightbend.akka.management:akka-management_2.13☕org.apache.pekko:pekko-management_2.13☕org.apache.pekko:pekko-management_3☕com.lightbend.akka.management:akka-management_2.12☕com.lightbend.akka.management:akka-management_3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

If you enable Basic Authentication in Pekko Management using the Java DSL, the authenticator may not be properly applied.

Users that rely on authentication instead of making sure the Management API ports are only available to trusted users are recommended to upgrade to version 1.1.1, which fixes this issue.

Akka was affected by the same issue and has released the fix in version 1.6.1.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.pekko:pekko-management_2.12all versions1.1.1org.apache.pekko:pekko-management_2.12:1.1.1
☕Mavencom.lightbend.akka.management:akka-management_2.13all versions1.6.1com.lightbend.akka.management:akka-management_2.13:1.6.1
☕Mavenorg.apache.pekko:pekko-management_2.13all versions1.1.1org.apache.pekko:pekko-management_2.13:1.1.1
☕Mavenorg.apache.pekko:pekko-management_3all versions1.1.1org.apache.pekko:pekko-management_3:1.1.1
☕Mavencom.lightbend.akka.management:akka-management_2.12all versions1.6.1com.lightbend.akka.management:akka-management_2.12:1.6.1
☕Mavencom.lightbend.akka.management:akka-management_3all versions1.6.1com.lightbend.akka.management:akka-management_3:1.6.1

Affected Products

2 products · 2 configurations
Application
akka managementakka
< 1.6.1
range
Application
pekko managementapache
≥ 1.0.0 && ≤ 1.1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.pekko:pekko-management_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.pekko:pekko-management_2.12 to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-46548 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

If you enable Basic Authentication in Pekko Management using the Java DSL, the authenticator may not be properly applied. Users that rely on authentication instead of making sure the Management API ports are only available to trusted users are recommended to upgrade to version 1.1.1, which fixes this issue. Akka was affected by the same issue and has released the fix in version 1.6.1.
O3 Security · Impact-Aware SCA

Is CVE-2025-46548 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-46548: pekko-management_2.12 — Fixed in 1.1.1