NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-43793 — com.liferay.portal.impl

HIGH

CVE-2025-43793 is a high-severity (CVSS 7.5) CWE-1284 vulnerability in com.liferay.portal:com.liferay.portal.impl. A fix is available for com.liferay.portal:com.liferay.portal.impl — see the affected versions and patch details below.

Liferay Portal has Improper Validation of Specified Quantity in Input

Also known asGHSA-xvgg-9h29-4g34
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-43793.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs35th percentile — riskier than 35% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕com.liferay.portal:com.liferay.portal.impl☕com.liferay.portal:com.liferay.portal.kernel

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Liferay Portal 7.4.0 through 7.4.3.105, and older unsupported versions, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions may incorrectly identify the subdomain of a domain name and create a supercookie, which allows remote attackers who control a website that share the same TLD to read cookies set by the application.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay.portal:com.liferay.portal.implall versions96.0.0com.liferay.portal:com.liferay.portal.impl:96.0.0
☕Mavencom.liferay.portal:com.liferay.portal.kernelall versions130.0.1com.liferay.portal:com.liferay.portal.kernel:130.0.1

Affected Products

2 products · 138 configurations
Application
digital experience platformliferay
≥ 2023.q3.1 && < 2023.q3.5
3 versions
7.37.42023.q4.0
Application
liferay portalliferay
< 7.4.3.106
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:com.liferay.portal.impl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay.portal:com.liferay.portal.impl to 96.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-43793 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Liferay Portal 7.4.0 through 7.4.3.105, and older unsupported versions, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions may incorrectly identify the subdomain of a domain name and create a supercookie, which allows remote attackers who control a website that share the same TLD to read cookies set by the application.
O3 Security · Impact-Aware SCA

Is CVE-2025-43793 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-43793: com.liferay.portal.impl — Fixed in 96.0.0