NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-43783 — com.liferay.frontend.edit…

MEDIUMFix: liferay/liferay-portal@d7f9e94

CVE-2025-43783 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.frontend.editor.ckeditor.web. A fix is available for com.liferay:com.liferay.frontend.editor.ckeditor.web — see the affected versions and patch details below.

Liferay Portal is vulnerable to Reflected XSS attack through get_editor path

Also known asGHSA-jhgr-j9cj-8j62
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-43783.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs16th percentile — riskier than 16% of all scored CVEsHighest risk
0.00%0.25%0.50%0.75%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.liferay:com.liferay.frontend.editor.ckeditor.web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A reflected cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.3.73 through 7.4.3.128, and Liferay DXP 2024.Q3.0 through 2024.Q3.1, 2024.Q2.0 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.12, 7.4 update 73 through update 92 allows remote attackers to inject arbitrary web script or HTML via the /c/portal/comment/discussion/get_editor path.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.frontend.editor.ckeditor.web≥ 5.0.76&&< 5.0.1025.0.102com.liferay:com.liferay.frontend.editor.ckeditor.web:5.0.102

Affected Products

2 products · 24 configurations
Application
digital experience platformliferay
≥ 2024.Q3.0 && ≤ 2024.q2.13
1 version
7.4
Application
liferay portalliferay
≥ 7.4.0 && < 7.4.3.129
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.frontend.editor.ckeditor.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.frontend.editor.ckeditor.web to 5.0.102 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-43783 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A reflected cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.3.73 through 7.4.3.128, and Liferay DXP 2024.Q3.0 through 2024.Q3.1, 2024.Q2.0 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.12, 7.4 update 73 through update 92 allows remote attackers to inject arbitrary web script or HTML via the /c/portal/comment/discussion/get_editor path.
O3 Security · Impact-Aware SCA

Is CVE-2025-43783 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-43783: com.liferay.frontend — Fixed in 5.0.102