NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-43775 — com.liferay.client.extens…

MEDIUMFix: liferay/liferay-portal@e54b2b4

CVE-2025-43775 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.client.extension.web. A fix is available for com.liferay:com.liferay.client.extension.web — see the affected versions and patch details below.

Liferay Portal is vulnerable to XSS attacks via its remote app title field

Also known asGHSA-88g3-pv3w-5wmr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-43775.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk
0.00%0.24%0.48%0.72%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.liferay:com.liferay.client.extension.web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A stored cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.0 through 7.4.3.128, and Liferay DXP 2024.Q3.0 through 2024.Q3.5, 2024.Q2.0 through 2024.Q2.12, 2024.Q1.1 through 2024.Q1.12, and 7.4 GA through update 92 allows remote attackers to inject arbitrary web script or HTML via remote app title field.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.client.extension.web≥ 1.0.71&&< 2.0.272.0.27com.liferay:com.liferay.client.extension.web:2.0.27

Affected Products

2 products · 5 configurations
Application
digital experience platformliferay
≥ 2024.Q3.0 && ≤ 2024.q2.13
1 version
7.4
Application
liferay portalliferay
≥ 7.4.0 && < 7.4.3.129
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.client.extension.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.client.extension.web to 2.0.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-43775 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A stored cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.0 through 7.4.3.128, and Liferay DXP 2024.Q3.0 through 2024.Q3.5, 2024.Q2.0 through 2024.Q2.12, 2024.Q1.1 through 2024.Q1.12, and 7.4 GA through update 92 allows remote attackers to inject arbitrary web script or HTML via remote app title field.
O3 Security · Impact-Aware SCA

Is CVE-2025-43775 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-43775: com.liferay.client XSS — Fixed in 2.0.27