NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2025-43585 — project-community-edition

HIGH

CVE-2025-43585 is a high-severity (CVSS 8.2) CWE-285 vulnerability in magento/project-community-edition. A fix is available for magento/project-community-edition — see the affected versions and patch details below.

Adobe Commerce | Improper Authorization (CWE-285)

Also known asGHSA-r487-9vv5-75gg
Published
Updated
Affected
8 pkgs
Patched
3 / 8
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-43585.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.36%0.73%1.09%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

8 pkgs affected
🐘magento/project-community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access leading to a limited impact to confidentiality and a high impact to integrity. Exploitation of this issue does not require user interaction.

Affected Packages

8 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/project-community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p62.4.7-p6composer require magento/community-edition:^2.4.7-p6
🐘Packagistmagento/community-edition≥ 2.4.6-p1&&< 2.4.6-p112.4.6-p11composer require magento/community-edition:^2.4.6-p11
🐘Packagistmagento/community-editionall versions2.4.5-p13composer require magento/community-edition:^2.4.5-p13
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

3 products · 104 configurations
Application
commerceadobe
5 versions
2.4.42.4.52.4.62.4.72.4.8
Application
commerce b2badobe
5 versions
1.3.31.3.41.3.51.4.21.5.2
Application
magentoadobe
4 versions
2.4.52.4.62.4.72.4.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/project-community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2025-43585; check the affected-versions list above or the advisory for the patched release of magento/project-community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access leading to a limited impact to confidentiality and a high impact to integrity. Exploitation of this issue does not require user interaction.
O3 Security · Impact-Aware SCA

Is CVE-2025-43585 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-43585: project-community — Fixed in 2.4.7-p6