CVE-2025-41115 is a critical-severity (CVSS 10) CWE-266 vulnerability in github.com/grafana/grafana. EPSS puts its 30-day exploitation probability at 17.5% (97th percentile). A fix is available for github.com/grafana/grafana — see the affected versions and patch details below.
Incorrect privilege assignment
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-41115.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/grafana/grafana🐹github.com/grafana/grafana🐹github.com/grafana/grafana🐹github.com/grafana/grafanaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
SCIM provisioning was introduced in Grafana Enterprise and Grafana Cloud in April to improve how organizations manage users and teams in Grafana by introducing automated user lifecycle management.
In Grafana versions 12.x where SCIM provisioning is enabled and configured, a vulnerability in user identity handling allows a malicious or compromised SCIM client to provision a user with a numeric externalId, which in turn could allow to override internal user IDs and lead to impersonation or privilege escalation.
This vulnerability applies only if all of the following conditions are met:
enableSCIMfeature flag set to trueuser_sync_enabledconfig option in the[auth.scim]block set to true
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/grafana/grafana | ≥ 12.0.0&&< 12.0.7 | 12.0.7go get github.com/grafana/grafana@v12.0.7 |
| 🐹Go | github.com/grafana/grafana | ≥ 12.1.0&&< 12.1.4 | 12.1.4go get github.com/grafana/grafana@v12.1.4 |
| 🐹Go | github.com/grafana/grafana | ≥ 12.2.0&&< 12.2.2 | 12.2.2go get github.com/grafana/grafana@v12.2.2 |
| 🐹Go | github.com/grafana/grafana | ≥ 1.9.2-0.20250310110405-e6fdb746f235&&< 1.9.2-0.20251106142618-ca5d89812015 | 1.9.2-0.20251106142618-ca5d89812015go get github.com/grafana/grafana@v1.9.2-0.20251106142618-ca5d89812015 |
Affected Products
grafanagrafanaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/grafana/grafana, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/grafana/grafana to 12.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-41115 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
No Red Hat products or offerings are affected by this vulnerability. As the version of grafana (9.x/10.x) shipped in this version of Red Hat Enterprise Linux is not vulnerable to this CVE. The vulnerable versions listed in the CVE posting are >= 12.0.x which are all not in Red Hat Enterprise Linux.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-41115 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-41115 in your dependencies?
Find it across Go, including transitive dependencies.