NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-3602 — com.liferay.portal.vulcan…

HIGHFix: liferay/liferay-portal@6c6dad3

CVE-2025-3602 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in com.liferay:com.liferay.portal.vulcan.impl. A fix is available for com.liferay:com.liferay.portal.vulcan.impl — see the affected versions and patch details below.

Liferay Portal does not limit the depth of a GraphQL queries

Also known asGHSA-8c26-xm99-53w7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-3602.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.5%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.liferay:com.liferay.portal.vulcan.impl

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Liferay Portal 7.4.0 through 7.4.3.97, and Liferay DXP 2023.Q3.1 through 2023.Q3.2, 7.4 GA through update 92, 7.3 GA through update 35, and 7.2 fix pack 8 through fix pack 20 does not limit the depth of a GraphQL queries, which allows remote attackers to perform denial-of-service (DoS) attacks on the application by executing complex queries.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.portal.vulcan.implall versions5.0.103com.liferay:com.liferay.portal.vulcan.impl:5.0.103

Affected Products

2 products · 57 configurations
Application
digital experience platformliferay
≥ 2023.q3.1 && ≤ 2023.q3.2
3 versions
7.27.37.4
Application
liferay portalliferay
≥ 7.4.0 && ≤ 7.4.3.97
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.portal.vulcan.impl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.portal.vulcan.impl to 5.0.103 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-3602 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

Liferay Portal 7.4.0 through 7.4.3.97, and Liferay DXP 2023.Q3.1 through 2023.Q3.2, 7.4 GA through update 92, 7.3 GA through update 35, and 7.2 fix pack 8 through fix pack 20 does not limit the depth of a GraphQL queries, which allows remote attackers to perform denial-of-service (DoS) attacks on the application by executing complex queries.
O3 Security · Impact-Aware SCA

Is CVE-2025-3602 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-3602: com.liferay.portal DoS — Fixed in 5.0.103