NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2025-3446 — server

MEDIUM

CVE-2025-3446 is a medium-severity (CVSS 4.3) CWE-863 vulnerability in github.com/mattermost/mattermost/server/v8. A fix is available for github.com/mattermost/mattermost/server/v8 — see the affected versions and patch details below.

Members Without Guest Invite Permissions Can Add Guests to Teams

Also known asGHSA-r7r2-m3vr-c8qcGO-2025-3693
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-3446.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.25%0.50%0.76%0.2%0.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to check the correct permissions which allows authenticated users who only have permission to invite non-guest users to a team to add guest users to that team via the API to add a single user to a team.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.6.0&&< 10.6.210.6.2go get github.com/mattermost/mattermost/server/v8@v10.6.2
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.5.0&&< 10.5.310.5.3go get github.com/mattermost/mattermost/server/v8@v10.5.3
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.4.0&&< 10.4.510.4.5go get github.com/mattermost/mattermost/server/v8@v10.4.5
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.11.0&&< 9.11.129.11.12go get github.com/mattermost/mattermost/server/v8@v9.11.12
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20250415054241-76ab3867b785go get github.com/mattermost/mattermost/server/v8@v8.0.0-20250415054241-76ab3867b785

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 10.6.0 && < 10.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost/server/v8, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost/server/v8 to 10.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-3446 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Mattermost versions 10.6.x <= 10.6.1, 10.5.x <= 10.5.2, 10.4.x <= 10.4.4, 9.11.x <= 9.11.11 fail to check the correct permissions which allows authenticated users who only have permission to invite non-guest users to a team to add guest users to that team via the API to add a single user to a team.
O3 Security · Impact-Aware SCA

Is CVE-2025-3446 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-3446: server — Fixed in 10.6.2