NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2025-32973 — xwiki-platform-component-…

CRITICALFix: xwiki/xwiki-platform@1a6f1b2

CVE-2025-32973 is a critical-severity (CVSS 9) CWE-862 vulnerability in org.xwiki.platform:xwiki-platform-component-wiki. A fix is available for org.xwiki.platform:xwiki-platform-component-wiki — see the affected versions and patch details below.

org.xwiki.platform:xwiki-platform-component-wiki provides no warning when granting XWiki.ComponentClass programming right

Also known asGHSA-x7wv-5qg4-vmr6
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32973.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs35th percentile — riskier than 35% of all scored CVEsHighest risk
0.00%0.94%1.87%2.81%2.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.xwiki.platform:xwiki-platform-component-wiki☕org.xwiki.platform:xwiki-platform-component-wiki☕org.xwiki.platform:xwiki-platform-component-wiki

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

When a user with programming right edits a document in XWiki that was last edited by a user without programming right and contains an XWiki.ComponentClass, there is no warning that this will grant programming right to this object. An attacker who created such a malicious object could use this to gain programming right on the wiki. For this, the attacker needs to have edit right on at least one page to place this object and then get an admin user to edit that document.

To reproduce the problem, as a user without programming right, add an object of type XWiki.ComponentClass to any page and then edit the page as a user with programming right. There should be warning displayed, if not, the XWiki installation is vulnerable.

While such a warning didn't exist in any version of XWiki, only in XWiki 15.9 RC1 these kinds of warnings have been introduced which is why this is considered the first version that has this vulnerability. Before that, the advice was to be careful when editing pages edited by untrusted users.

Patches

This problem has been patched in XWiki 15.10.2, 16.4.3, and 16.8.0 RC1.

Workarounds

We're not aware of any workarounds apart from not editing pages that might have been edited by untrusted users as a user with programming rights, e.g., by using separate user accounts for admin and non-admin tasks.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.xwiki.platform:xwiki-platform-component-wiki≥ 15.9-rc-1&&< 15.10.1215.10.12org.xwiki.platform:xwiki-platform-component-wiki:15.10.12
☕Mavenorg.xwiki.platform:xwiki-platform-component-wiki≥ 16.0.0-rc-1&&< 16.4.316.4.3org.xwiki.platform:xwiki-platform-component-wiki:16.4.3
☕Mavenorg.xwiki.platform:xwiki-platform-component-wiki≥ 16.5.0-rc-1&&< 16.8.0-rc-116.8.0-rc-1org.xwiki.platform:xwiki-platform-component-wiki:16.8.0-rc-1

Affected Products

1 product · 3 configurations
Application
xwikixwiki
≥ 16.5.0 && < 16.8.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-component-wiki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.xwiki.platform:xwiki-platform-component-wiki to 15.10.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32973 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact When a user with programming right edits a document in XWiki that was last edited by a user without programming right and contains an `XWiki.ComponentClass`, there is no warning that this will grant programming right to this object. An attacker who created such a malicious object could use this to gain programming right on the wiki. For this, the attacker needs to have edit right on at least one page to place this object and then get an admin user to edit that document. To reproduce the problem, as a user without programming right, add an object of type `XWiki.ComponentClass` to a
O3 Security · Impact-Aware SCA

Is CVE-2025-32973 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-32973: Fixed in 15.10.12 (Critical 9)