CVE-2025-32971 is a low-severity (CVSS 3.8) CWE-863 vulnerability in org.xwiki.platform:xwiki-platform-search-solr-api. A fix is available for org.xwiki.platform:xwiki-platform-search-solr-api — see the affected versions and patch details below.
XWiki Solr script service doesn't take dropped programming right into account
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32971.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-search-solr-api☕org.xwiki.platform:xwiki-platform-search-solr-api☕org.xwiki.platform:xwiki-platform-search-solr-apiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The Solr script service that is accessible in XWiki's scripting API normally requires programming right to be called. Due to using the wrong API for checking rights, it doesn't take the fact into account that programming rights might have been dropped by calling $xcontext.dropPermissions(). If some code relies on this for the safety of executing Velocity code with the wrong author context, this could allow a user with script right to either cause a high load by indexing documents or to temporarily remove documents from the search index. We're not aware that this is exploitable in XWiki itself.
To reproduce, a user with programming right can add the following XWiki syntax to a page:
{{velocity}}
$xcontext.dropPermissions()
$services.solr.index('document:xwiki:Main.WebHome')
{{/velocity}}
This should trigger an error in XWiki's log, otherwise the installation is vulnerable.
Patches
This has been patched in XWiki 15.10.13, 16.8.0RC1, and 16.4.4.
Workarounds
We're not aware of any workarounds apart from being careful whom you grant script right.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-search-solr-api | ≥ 4.5.1&&< 15.10.13 | 15.10.13org.xwiki.platform:xwiki-platform-search-solr-api:15.10.13 |
| ☕Maven | org.xwiki.platform:xwiki-platform-search-solr-api | ≥ 16.0.0-rc-1&&< 16.4.4 | 16.4.4org.xwiki.platform:xwiki-platform-search-solr-api:16.4.4 |
| ☕Maven | org.xwiki.platform:xwiki-platform-search-solr-api | ≥ 16.5.0-rc-1&&< 16.8.0-rc-1 | 16.8.0-rc-1org.xwiki.platform:xwiki-platform-search-solr-api:16.8.0-rc-1 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-search-solr-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-search-solr-api to 15.10.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32971 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-32971 in your dependencies?
Find it across Maven, including transitive dependencies.